IsatPhonePro Mandatory Firmware Upgrade 2013

There is a MANDATORY firmware upgrade available for the IsatPhonePro handset. Owners must upgrade to firmware 5.3.0 (or later) before 31st December 2013 or the handset may have problems connecting to the network.

Links to the instructions to upgrade your firmware to version 5.3.0 (or later) can be found in our Inmarsat IsatPhonePro Support section

 
0: PCFWarn: Markup_e was called from /var/www/www.mailasail.com/htdocs/w/local/farmconfig.php line 302 1 time! (function created)